System requirements

Telephone systems

In principle you can use any TC system that you usually use for ProCall, even together with ProCall Analytics.

However for a correct evaluation of call groups, the TC system must be connected via ECSTA-driver. This is due to technical limitation in the tracking of complex call forwarding scenarios that may arise when connecting via the most common TAPI drivers.

ECSTA TAPI drivers excluded from this rule include:

  • ECSTA for SIP phones
  • ECSTA for snom

For all other system drivers, please read the list of the telephone systems tested by us. In this article, you can also find information about how you can check whether your system correctly indicates the group calls without the ECSTA connection.

HowTo: Whitelist about telephone systems for complex group call scenarios in the ProCall Analytics environment

Hardware requirements

Analytics standalone

  • Free RAM: 2 GB
  • At least 3 Ghz CPU
  • approx. 1 GByte HDD

Note: These parameters refer to a system on which no other applications are installed. If other applications are running on your computer, the requirement for the entire system increases accordingly.

Operating system

A server operating system is required for the productive use of ProCall Analytics. The following server operating systems are supported:

  • Windows Server® 2008 R2 (SP2)
  • Windows Server® 2012
  • Windows Server® 2012 R2
  • Windows Server® 2016

On workstation operating systems, ProCall Analytics can only be installed in test mode (predefined example data, no database or UCServer connection). As Microsoft® has severely restricted access from other computers to a workstation, due to technical reasons it is no longer possible to access ProCall Analytics from another computer. Access is only possible via http://localhost from the computer itself on which ProCall Analytics was installed. If you want to test access from another computer, please select a server operating system. The following workstation operating systems are supported:

  • Windows® 7 SP1
  • Windows® 8.1
  • Windows® 10

Licensing

To be able to use ProCall Analytics productively, you will require ProCall Analytics licenses. The number of required licenses must at least correspond to the number of ProCall workplace licenses. If you have not purchased a license, ProCall Analytics operates in test mode and you will get predefined example data displayed.

Software components

  • .NET Framework 4.6.2
    If this is not provided, ProCall Analytics setup tries to download this framework from the Internet. If the computer does not have Internet access, you can also download the setup for free from Microsoft® and then execute it on the Windows Server® that you have provided for the ProCall Analytics installation. Check this URL for downloading .NET Framework:
    https://www.microsoft.com/download/details.aspx?id=53344
  • estos UCServer
    Version 4.1.13 or higher. estos UCServer must not run on the same computer as ProCall Analytics. It is even advantageous to install ProCall Analytics on its own computer to increase performance and reliability. estos UCServer must use a Microsoft SQL Server® as a database. Access cannot be used with ProCall Analytics.

    The following Knowledge Base article describes the configuration of estos UCServer and the connection of the database:
    https://helpdesk.estos.de/Knowledgebase/Article/View/1/0/howto-umstellung-der-ucserver-datenbank-auf-sql-server--sql-express

    Important: Please make sure that the TCP protocol has been activated in the SQL Configuration Manager. Also make sure that the SQL Server® Browser Service is running. Otherwise ProCall Analytics will not find its database.

  • MS-SQL Server®
    The following are supported: MSSQL 2008, MSSQL 2008R2, MSSQL 2012, MSSQL 2014 and MSSQL 2016. Either the free Express version of the MS-SQL Server® or the more powerful Enterprise Version of the MS-SQL Server® can be used.

Supported browsers

  • Microsoft® Internet Explorer®, version 9 or higher
  • Microsoft® Edge (version 25.10586.0.0 or higher)
  • Firefox®, version 17 or higher
  • Google Chrome™ browser, version 24 or higher
  • Safari 5 and 6 Mobile (iOS 8, iPad®, Mac OS® X)

Version 6.0